+1.7 Sidebar appears only on homepage

  • Stylite

    #4530

    Hello,

    Yesterday night I did an update from 1.6x to 1.7. I ran into some problems, which I could only fix partially.

    The remaining problem is this:

    – I cannot see my sidebar and its content on all pages, only on the home page.

    All pages are in ‘Theme standard’ template. I wish to keep it like this, because I use a Post Type Manager plugin with a Post Type Archives plugin. Those plugins generate 2 pages (Onze paarden & Het manegeteam). I cannot set a template on those pages; they take the Theme standard, as far as I can see. Therefore, I need to have the Theme standard template working.

    Even when switching normal pages to other Theme templates, only the templates with a sidebar on the right do show the widgets as should. But as I wrote above, that’s no option.

    I have no areas set to ‘display: none;’ in the CSS, except for the upper menu bar (#header-menu-wrap). The owners insist on a vertical menu, so using the horizontal is no option. I have a child theme, but this only overrules the CSS, no php’s.

    This site is already live and I can hardly do any experimenting, unless after midnight (GMT+1). Yet still the owners want it fixed asap, as usual 😉

    Note: don’t bother about the footer; I have to revise that. Hardcoded it into the Graphene footer settings now. I have to activate the extra footer and get the 3 columns in there as 3 separate widgets. No worries.

    Thanks on beforehand. I’m overall pretty happy with this theme, just not with updates like these…

    Stylite

    #28471

    It is weird, but tonight I was switching themes a bit, and when I went back to my Graphene theme, the menu bar was suddenly there. I moved to my Graphene Child theme, and it was still there. I have no idea what solved it. I didn’t do a new update, the files remained the same. Maybe it was something with the action hooks…? I haven’t dug into that but I read it somewhere.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!